Limbo

45 Linux Buffer Overflow - Crossfire | Offensive Security Certified Professional

Linux Buffer Overflow in Crossfire with linux server Offensive Security Certified Professional (OSCP) video series by Ahmed: https://www.linkedin.com/in/limb...
There are no comments to display.

Media information

Album
OSCP
Added by
Limbo
Date added
View count
301
Comment count
0
Rating
0.00 star(s) 0 ratings

Caption

Code:
#!/bin/bash
sudo apt-get update -y
sudo apt-get install -y edb-debugger
sudo dpkg --add-architecture i386
sudo echo "foreign-architecture i386" > /etc/dpkg/dpkg.cfg.d/multiarch
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install multiarch-support
sudo apt-get install libxaw7 libxaw7-dev -y
sudo apt install checksec
wget www.offensive-security.com/crossfire.tar.gz
tar -zxf crossfire.tar.gz
sudo cp -r crossfire /usr/games/
checksec --file=/usr/games/crossfire/bin/crossfire
To disable NX
Code:
sudo nano /etc/default/grub
#add this line with GRUB_CMDLINE_LINUX_DEFAULT="quiet
#To be
#GRUB_CMDLINE_LINUX_DEFAULT="quiet noexec=off noexec32=off"
noexec=off noexec32=off
sudo update-grub

Share this media

Top